徒然FreeSoft

アクセスカウンタ

zoom RSS Win7 64bit 不明なデバイスが消えない! ACPI AWY0001 2&DABA3FF&1

<<   作成日時 : 2011/09/25 12:47  

なるほど(納得、参考になった、ヘー) ブログ気持玉 2 / トラックバック 1 / コメント 7

倒れそうなくらい暑かった夏が懐かしくなるような爽やかな季節がやってきました。何とかの秋とは言いますが、どんな秋になるでしょうか?

先日デスクトップPCのレジストリにクリーナー処理をしたところ、再起動できなくなりました。
どうもレジストリを壊してしまったようで、不覚にもバックアップを取っていませんでした。思案の末にたどり着いた結論は、再インストールでした。幸いデータファイルはルートドライブ以外のHDDを使用していましたので最小限の復旧で済むはずです。

Win7のインストールディスクから64bitバージョンを再インストール。PCは無事起動し、環境設定やらアプリのインストールやらで1日を費やしてしましました。

大体のPC環境を整え、(冷静になって?)設定状況を見なおしてみますと・・・・・。
デバイスマネージャに不明なデバイスの表示がでているではありませんか。私の使用しているPCはDell:Inspiron531Sでして、CPUはAMD製です。

デバイスエラーの内容を追いかけると、

PnPデバイス ACPI\AWY0001\2&DABA3FF&1 エラーコード28

となっています。

このAWY・・・エラーについてググッて見ました。
AMD製CPUかつWindows64bit使用時に発生する・・・との記事が多くあります。とはいってもこれといった解決策がなかなか得られませんでした。MSの解説によれば重大な問題ではないとありましたが、私の性格上?エラーの存在は許せません(笑)
AWY問題の詳細は割愛しますが、お困りの方はお調べ下さい。

なおもググると海外サイトに「awymode.inf」なるドライバーの適用で解決できるとありました。半信半疑ながらサイトに記述されたテキストから「awymode.inf」をテキストエディターで作成して、デバイスマネージャからドライバーをインストールすると、いとも簡単にエラーは消え去りました。

BIOS上でAMD AliveをDisableする対処方法もあるようですが、私が使用しているBIOSでは設定変更できませんでした。

■awymode.infの内容

;*******************************************
; AmdAway.inf
; Null INF for "AwayMode" ACPI device
; Version 1.0.1.0
; (C) Copyright 2006 AMD, Inc.
;*******************************************

[Version]
Signature="$WINDOWS NT$"
Class=System
ClassGuid={4D36E97D-E325-11CE-BFC1-08002BE10318}
Provider=%AMD%
DriverVer=04/06/2006, 1.0.1.0
CatalogFile=AmdAway.cat

[ControlFlags]
ExcludeFromSelect=*

[Manufacturer]
%AMD_MFG% = AWAY_MODE,NTamd64

[SourceDisksNames]

[SourceDisksFiles]

[AWAY_MODE]
%*pnpffff.DeviceDesc% = NULL_DRIVER, *pnpffff
%*pnpffff.DeviceDesc% = NULL_DRIVER, ACPI\AWY0001

[AWAY_MODE.NTamd64]
%*pnpffff.DeviceDesc% = NULL_DRIVER, *pnpffff
%*pnpffff.DeviceDesc% = NULL_DRIVER, ACPI\AWY0001

[NULL_DRIVER]

[NULL_DRIVER.Services]
AddService = , %SPSVCINST_ASSOCSERVICE% ; null service install

[Strings]
AMD = "AMD"
AMD_MFG = "AMD"
*pnpffff.DeviceDesc = "AMD AwayMode"

;*******************************************
;Handy macro substitutions (non-localizable)
;*******************************************
SPSVCINST_ASSOCSERVICE = 0x00000002


同様のお悩みをお持ちの方、Good Luck!


テーマ

関連テーマ 一覧


月別リンク

ブログ気持玉

クリックして気持ちを伝えよう!
ログインしてクリックすれば、自分のブログへのリンクが付きます。
→ログインへ
気持玉数 : 2
なるほど(納得、参考になった、ヘー)
ナイス

トラックバック(1件)

タイトル (本文) ブログ名/日時
フェラガモ アウトレット
Win7 64bit 不明なデバイスが消えない! ACPI AWY0001 2&DABA3FF&1 徒然FreeSoft/ウェブリブログ ...続きを見る
フェラガモ アウトレット
2013/07/03 10:54

トラックバック用URL help


自分のブログにトラックバック記事作成(会員用) help

タイトル
本 文

コメント(7件)

内 容 ニックネーム/日時
私も同じ機種でWin7-64にアップして同じことでいろいろ探していました。あっさり解決しました。ありがとうございました。
FPTT
2011/10/03 21:30
私の経験を投稿することで皆様のお役に立てて幸いです。
徒然FreeSoft
2011/10/04 00:03
貴重な情報ありがとうございました。
娘の同一マシーンでも同じ現象が起きてました。
あっさり直りました。
ありがとうございました。
IMA
2012/01/01 10:13
自作PCかつ64bit OSではありませんでしたが解決しました。
ありがとうございます!

ちなみにOSはVista sp2 32bitです。
nap
2012/10/07 18:11
お知恵拝借致しました。
見事に解決致し感謝に堪えません。
tm
2012/10/20 14:49
VIsta 32bitでしたが、テキストエディター
拡張子などなど、ドライバインストでいろいろと勉強になりました。
ありがとうございました。
bana
2014/07/06 13:19
おかげさまで解決いたしました。
非常に有意義な情報に感謝感謝です。
hide
2014/10/13 00:28

コメントする help

ニックネーム
本 文
Win7 64bit 不明なデバイスが消えない! ACPI AWY0001 2&DABA3FF&1 徒然FreeSoft/BIGLOBEウェブリブログ
文字サイズ:       閉じる